Главная arrow Статьи arrow Нарушена уникальность кодов справочника

Программа поддержки

Скачать

Карта сайта

Карта сайта
Форум
Нарушена уникальность кодов справочника
Написал Обслуживание 1С Одесса   

Как изменить номера элементов справочника в 1С 7.7

В некоторых случаях  приходится сталкиваться с ошибкой: "Нарушены правила уникальности кодов справочника". Или может быть коды справочника были введены не правильно.
В этом случие необходимо перенумеровать элементы справочника с помощьювнешней обработки (renumber.ert).
 
Код у спр. номенклатура текстовый с ведущими нулями, поэтому тут нужна вот такая процедура:

1. Сделать резервную копию базы.
2. Выполняем обработку

Процедура Сформировать()
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    К=0;
    НачатьТранзакцию();
    Пока Спр.ПолучитьЭлемент()=1 цикл   
        Если Окр(К/100)=К/100 Тогда // Транзакция по 100 элементов
            ЗафиксироватьТранзакцию();
            НачатьТранзакцию();
        КонецЕсли;
        К=К+1;
        мЭлемент=Спр.ТекущийЭлемент();
        мЭлемент.код=Формат(К,"Ч(0)5"); // 5- длина кода в справочнике номенклатура
        сообщить(спр.код);
        мЭлемент.Записать();
    КонецЦикла;
    ЗафиксироватьТранзакцию();
КонецПроцедуры

Скачать обработку renum.ert


Последнее обновление ( 01.08.2010 )
 
< Пред.   След. >